Berry Confused

A friend with a Blackberry 8320 smashed its pretty face against something. Cracked lens! By the time I told him he could fix it, he’d replaced it! Now it’s mine. Fixing the lens was easy–and I’m a major klutz.

It was originally on T-Mobile. It’s been unlocked, so it can go on AT&T and the phone and texting works fine.

It mostly works OK for Twitter and Facebook and some other apps, but when I go to use the browser I’m told: “This is a Wi-Fi service. Please ensure your device has an active Wi-Fi connection and try again.”

I have a plan from AT&T which includes data, though I haven’t moved this to their Blackberry plan yet (for my daughter, there was no cost differential). I see “edge” not “EDGE” which I believe enters into this.

Anyone know how to fix this?

2 Responses to “Berry Confused”

  1. You may have tried this already, but here’s a solution from somebody with your exact same problem:

    From: http://www.tomtatedesigns.com/wordpress/2008/07/18/blackberry-browser-broken-this-is-a-wifi-service-what/

    1. Go to Options > Advanced Options > Browser

    2. Select Internet Browser as the Default browser configuration. It’s most likely Hotspot Browser if you’re having the same problem. Mine was.

    3. Escape out. Save changes.

  2. Geoff Fox says:

    No– I don’t have the Internet browser available, probably

    because it’s not officially registered as a BB on AT&T.

    If I don’t register right away I might just get the Opera Mini browser for the time being. But I’ll still take a better solution.

Leave a reply

Current day month ye@r *